Frequently Asked Questions

Silhouette Troubleshooting >> Silhouette Design Store Issues >> Cannot access Silhouette Design Store through the software

Cannot access Silhouette Design Store through the software

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Issue Description

A "Navigation to the webpage was canceled" error is encountered when trying to access the Silhouette Design Store through the software. It appears as though there is no internet connection, though the internet can be accessed through a regular web browser. The Silhouette Design Store can be accessed through a regular web browser without concern.

Cause

This typically indicates that there is a firewall (such as Norton, McAfee, Windows Firewall, etc) blocking the Silhouette Studio® software program accessing the Silhouette Design Store through the computer's native web browser (Internet Explorer for PC; Safari for Mac). As software other than a regular web browser program attempts to access the internet, the firewall program on the computer in question jumps in determine if the program is allowed. In this case, it is cutting off the ability to access the internet through the program that has not been allowed by the firewall.

Another more rare cause can be that there is a concern with the settings of the Internet Explorer browser program (which the Silhouette Studio® software program uses to access the Silhouette Design Store, even if you have another default or preferred web browser).

Resolution

Begin by determining what firewall program is present on your computer. Often, this may be bundled into an antivirus software program. Once determined, access the antivirus/firewall program (such as Norton, McAfee, etc) and edit the "Allowed" programs for the firewall settings and "Allow" "Silhouette Studio" to have access to the internet.

As all antivirus and firewall programs are different in their setups, it is not possible to provide a specific walk-through for every program available. We can, however, relay that most often there is a section dealing with "Program Permissions", which is the likely section that needs adjustment to "Allow" the "Silhouette Studio" program.

If a specific firewall program cannot be found, check the default Windows Firewall program as follows:

Windows Vista/7/8/10

  1. Open the Control Panel
  2. Select Windows Firewall
  3. On left hand pane, select "Allow a program or feature through Windows Firewall"
  4. Click Change Settings and then click the Allow another program button.
  5. Select Silhouette Studio in the list that is displayed.
  6. Click Add
  7. Click OK (Silhouette Studio will be shown in the list with a tick in box)

Windows XP

  1. Open the Control Panel
  2. Open Security Center
  3. Click on Windows Firewall to open
  4. Click Exceptions (This displays a list of programs allowed to access the internet)
  5. Click on Add Programs
  6. Browse for Silhouette Studio, select it and press OK
  7. Press OK again to exit the Windows Firewall

Some computers have a hardware firewall which requires the user to allow an application through the firewall on demand. Often the firewall request is made during the time when Silhouette Studio is started up. If "NO" had been inadvertently selected when it was initially launched, then access to the internet is not attainable during that session and generally an application only gets one chance to get permission for internet access. Once that chance is denied, the only way through is to restart the application and make sure you allow the program access.

If the above steps are not successful, proceed to check the Internet Explorer settings as follows:

  1. Open Internet Explorer
  2. Go to the Tools menu
  3. Select Internet Options
  4. Go to the Connections tab
  5. Select and REMOVE any connections listed under the Dial-up/VPN window
  6. Click on the LAN Settings in this Connections screen
  7. Check the Automatically Detect Settings option
  8. Click OK and Apply the settings
  9. Also in the Internet Options window, select the Advanced tab
  10. Select to Restore Advanced Settings
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